Page 1 of 1

Realtek PCie GBE Family Controller -won't work automatically

PostPosted: Fri Sep 25, 2015 7:35 pm
by joolsd
Realtek PCie GBE Family Controller (won't work automatically).

I have recently put a new instal of windows 7 on my PC. One thing that is strange is that the network card won't log in to the intenet straight away. This strangly enough happened in exactly the same way last year after a re-install.

I can get it going again, by 'randomly' using the advance settings. Which dosn't make muh sense. There is no pattern to why it works (after random tweaking) . I thought it might be the power management. It is working now as I am here talking to you.

It makes no sense that this device should not work after reboot.

The driver version is 7.6.820.2009,

Could there be a bug, or maybe the firewall is not accepting it.

There are settings such as 'Jumbo flame' 'Flow control'.. Means nothing to me, and there is no doumentation to explain what this does.

what are the actual settings to make this device work without me having to do anything else?

Many thanks
Best regards

Jools

Re: Realtek PCie GBE Family Controller -won't work automatic

PostPosted: Mon Sep 28, 2015 12:41 pm
by Gecko
Have you tried troubleshooting?
Right click on the Network icon and select "Troubleshoot problems"

Re: Realtek PCie GBE Family Controller -won't work automatic

PostPosted: Mon Sep 28, 2015 7:46 pm
by joolsd
Yes.

It just said

'Trouble shooting couldn't identify the problem.'

It is quite an annyoying problem, becuase it means I have to go into adimin to disable something in one of those settings.
and then it just works.

Re: Realtek PCie GBE Family Controller -won't work automatic

PostPosted: Tue Sep 29, 2015 8:48 pm
by Gecko
The first thing I would try is downloading drivers for the Realtek PCie GBE Family Controller saving them to your system.
Next I would uninstall the device, reboot and when the Realtek PCie GBE Family Controller is found use the drivers you downloaded.

Re: Realtek PCie GBE Family Controller -won't work automatic

PostPosted: Tue Sep 29, 2015 9:18 pm
by joolsd
Yes I did all that. I have tried using the latest download and the GIGABYTE software disk.

But I have been doing a bit of diging and I people have been suggesting it is a BIOS setting, GREEN LAN, SMART LAN.

But anyway I won't assume anything. I have done the obvious and tried installing the right driver.

Infact the only way I can get on to the web is bu re-installing the driver.

Could the intergrated network device be faulty?

Re: Realtek PCie GBE Family Controller -won't work automatic

PostPosted: Wed Sep 30, 2015 1:12 pm
by Gecko
joolsd wrote:Could the intergrated network device be faulty?

Yes it could be bad, however I would think that is not the case because you can make it work.

Open up Network and Sharing Center. You can find this by going to Start then typing Network and Sharing Center into the search box.

In the left window pane click Change adapter settings.

You will see all of your network adapters here which include the Ethernet and Wireless adapters.

Depending on what you are trying to fix, choose the appropriate adapter. Usually, Local Area Connection is your Ethernet adapter and Wireless Network Connection is your Wi-Fi adapter. Although, these might be named differently the default names are Local Area Connection and Wireless Network Connection.

Disable the adapter that is having issues with internet connectivity either by right clicking the adapter and selecting disable, or double clicking the adapter and choosing the disable button.

Re-enable the adapter by double clicking it. You can also re-enable it by right clicking on the adapter icon and selecting Enable.

See if it works

Re: Realtek PCie GBE Family Controller -won't work automatic

PostPosted: Wed Sep 30, 2015 7:54 pm
by joolsd
Ok I will try that. Thank you..

Jools

Re: Realtek PCie GBE Family Controller -won't work automatic

PostPosted: Fri Oct 02, 2015 6:39 am
by joolsd
Well, double clicking the 'change adapter setting', but it is not automatic. I believe it could be a bios setting so I will also look into this.

Re: Realtek PCie GBE Family Controller -won't work automatic

PostPosted: Wed Oct 21, 2015 2:40 pm
by PcTestCard.com
Try reset the Bios default, then look for the card in the Bios and see what state that is.
If enabled by default, try disable that, save exit.
Reboot to the Windows confirm the device not in the devices manager.
Next repeat the process again by enabling the device in Bios and save exit.
Reboot to the Windows and look for the device in the Device manager again.

Reintall the latest mobo chipset driver and reboot after that, hope the new chipset driver can help with the onboard devices integrity to work better together.

Next to do is check on the cable connection and the Lan card connection as well.
Oxidation may have caused the intermittent no work to the internet.
Maybe use the other working cable and clean the LAN card connection pins with a cotton stick carefully.

Hope this can get you the reliable internet connection again without manually enable that in the Windows periodically.

Bill
Tech Manager, WPTINC.