It is currently Fri Sep 22, 2017 10:51 am


PC dead but psu ok

All computer hardware support

PC dead but psu ok

Postby KenA » Wed Feb 06, 2013 1:26 pm

Hi guys, its been a while.

My dads PC has suddenly decided not to power up. First thing i thought was the PSU, so i replaced it but still the same.
I also bypasses the front switch but no joy. I also tried disconnecting the RAM.
It was an upgrade mobo i did last yr running windows xp, AMD x3 cpu and 2Gb RAM but has been running fine up to now.

Any ideas?
User avatar
KenA
Senior Geek
Senior Geek
 
Posts: 139
Joined: Wed Nov 16, 2005 1:00 am

Thanks given:1
Thanks received:0
Top

Re: PC dead but psu ok

Postby Gecko » Wed Feb 06, 2013 2:06 pm

KenA,

It sounds like the system isn't even reaching the POST (power on self test) because if it was reaching POST you would have gotten an error message about the ram.

Tracing down this type of failed power-up can be difficult, are there any daughter boards like sound card, network card or other device that plugs into the mother board?
If so try removing them one at a time and see if that resolve the boot-up issue.

I've also seen a bad mouse, a bad keyboard and a DVD drive cause this type of problem so check them as well.
You can also try disconnecting the hard drive to see if that will get you an error.

Otherwise you are looking at the motherboard or CPU as the culprit.

Who said thanks: KenA (Wed Feb 06, 2013 11:32 pm)
User avatar
Gecko
Super Moderator
Super Moderator
 
Posts: 5206
Joined: Thu Oct 25, 2001 1:00 am
Location: Florida, USA

Thanks given:1
Thanks received:23
Top

Re: PC dead but psu ok

Postby KenA » Wed Feb 06, 2013 11:31 pm

Its not reaching POST at all....not a tickle out of it. like as if the psu was dead.
theres no daughter boards attached, all are on the mobo.

As i said earlier, the motherboard and cpu were only installed by me last yr as an upgrade kit and has hardly gotten much use as his main device is his laptop.. :(

I havent disconnected any of the peripherals or the HDD yet so ill try that tomorrow and report back.
User avatar
KenA
Senior Geek
Senior Geek
 
Posts: 139
Joined: Wed Nov 16, 2005 1:00 am

Thanks given:1
Thanks received:0
Top

Re: PC dead but psu ok

Postby icecube » Sun Feb 10, 2013 1:28 am

I would suggest memory could be the issue. Disconnect the power to the MB. Pop them all out and try one stick at a time. Sometimes just reseating the memory will get it to boot up
User avatar
icecube
Moderator
Moderator
 
Posts: 1209
Joined: Wed Mar 10, 2004 1:00 am
Location: San Marcos Ca

Thanks given:0
Thanks received:0
Top


Return to Hardware

Who is online

Users browsing this forum: No registered users and 1 guest

cron