Page 1 of 1

Bulletproof FTP

PostPosted: Wed Jan 28, 2004 8:48 pm
by skeletor
I am running bulletproof ftp server 2.21 and I have a cable modem so I am always getting great speeds but for some reason most of my users who download do not get greater than 40kbytes/s and no more than 16kbytes/s for upload. Why is this? One has 1.5mbps dsl and the other has cable same as me. Am I setting it up wrong or is there something I can configure differently to get higher speeds?

PostPosted: Thu Jan 29, 2004 5:18 am
by NaTaS
Depends on the bandwidth alloted to you by your ISP. Normally upload speed is capped at around 40kB/s. Because its capped at 40kB, you will upload to them at that amount regardless of their download speed.

You can always head to www.speedguide.net for tweaks and patches to improve your speed, but you'll never go over your capped upload - unless of course you uncap your modem. If you do that, you'll have some FBI agents knocking at your door :D.

PostPosted: Thu Jan 29, 2004 2:33 pm
by skeletor
Well I went to that website and read some stuff and did some of their analyzers and optimizers. I ran some of their regedits but they decreased my preformance so I am guessing I am at the best I can get. Their is this one part called the tcp analyzer and this is what I got:
TCP options string = 020405b401010402
MTU = 1500
MTU is fully optimized for broadband.
MSS = 1460
Maximum useful data in each packet = 1460, which equals MSS.

Default Receive Window (RWIN) = 64240
RWIN Scaling (RFC1323) = 0 bits
Unscaled Receive Window = 64240

RWIN is a multiple of MSS
Other values for RWIN that might work well with your current MTU/MSS:
513920 (MSS x 44 * scale factor of 8)
256960 (MSS x 44 * scale factor of 4)
128480 (MSS x 44 * scale factor of 2)
bandwidth * delay product:

Your RcvWindow limits you to: 2569.6 kbps (321.2 KBytes/s) @ 200ms
Your RcvWindow limits you to: 1027.84 kbps (128.48 KBytes/s) @ 500ms
MTU Discovery (RFC1191) = ON
Time to live left = 118 hops

TTL value is ok.
Timestamps (RFC1323) = OFF
Selective Acknowledgements (RFC2018) = ON
IP type of service field (RFC1349) = 00000000


When I ran one of their regedits it changed
Your RcvWindow limits you to: 2569.6 kbps (321.2 KBytes/s) @ 200ms
Your RcvWindow limits you to: 1027.84 kbps (128.48 KBytes/s) @ 500ms

Your RcvWindow limits you to: 1026.0 kbps (these are somewhat exact)
Your RcvWindow limits you to: 4008.84 kbps
I didnt record them but the first numbers in each are correct.

PostPosted: Fri Jan 30, 2004 11:48 am
by Restek

PostPosted: Fri Jan 30, 2004 3:29 pm
by skeletor

PostPosted: Fri Jan 30, 2004 7:11 pm
by Restek